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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

 WARNING 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

 CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

 

 NOTICE 
indicates that property damage can result if proper precautions are not taken. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by Siemens. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication 
may be trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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Technical support  
 
Country Hotline 
China +86 400 810 4288 
Germany +49 911 895 7222 
Italy +39 (02) 24362000 
India +91 22 2760 0150 
Turkey +90 (216) 4440747  
Further service contact information:  
Support contacts (https://support.industry.siemens.com/cs/ww/en/ps) 

 

https://support.industry.siemens.com/cs/ww/en/ps
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 Fundamental safety instructions 1 
1.1 General safety instructions 
 

 WARNING 

Danger to life if the safety instructions and residual risks are not observed  

If the safety instructions and residual risks in the associated hardware documentation are 
not observed, accidents involving severe injuries or death can occur. 
• Observe the safety instructions given in the hardware documentation. 
• Consider the residual risks for the risk evaluation. 

 

 

 WARNING 

Danger to life or malfunctions of the machine as a result of incorrect or changed 
parameterization 

As a result of incorrect or changed parameterization, machines can malfunction, which in 
turn can lead to injuries or death. 
• Protect the parameterization (parameter assignments) against unauthorized access. 
• Respond to possible malfunctions by applying suitable measures (e.g. EMERGENCY 

STOP or EMERGENCY OFF). 
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1.2 Industrial security 
 

 Note 
Industrial security 

Siemens provides products and solutions with industrial security functions that support the 
secure operation of plants, solutions, machines, equipment and/or networks. They are 
important components in a holistic industrial security concept. With this in mind, Siemens’ 
products and solutions undergo continuous development. Siemens recommends strongly 
that you regularly check for product updates. 

For the secure operation of Siemens products and solutions, it is necessary to take suitable 
preventive action (e.g. cell protection concept) and integrate each component into a holistic, 
state-of-the-art industrial security concept. Third-party products that may be in use should 
also be considered. For more information about industrial security, visit this address 
(http://www.siemens.com/industrialsecurity).  

To stay informed about product updates as they occur, sign up for a product-specific 
newsletter. For more information, visit this address (http://support.automation.siemens.com).  

 

 WARNING 

Danger as a result of unsafe operating states resulting from software manipulation 

Software manipulation (e.g. by viruses, Trojan horses, malware, worms) can cause unsafe 
operating states to develop in your installation which can result in death, severe injuries 
and/or material damage. 
• Keep the software up to date. 

You will find relevant information and newsletters at this address 
(http://support.automation.siemens.com).  

• Incorporate the automation and drive components into a holistic, state-of-the-art 
industrial security concept for the installation or machine. 
You will find further information at this address 
(http://www.siemens.com/industrialsecurity).  

• Make sure that you include all installed products into the holistic industrial security 
concept. 

 

 

 WARNING 

Danger to life due to software manipulation when using exchangeable storage media 

Storing files onto exchangeable storage media amounts to an increased risk of infection, 
e.g. with viruses and malware. As a result of incorrect parameterization, machines can 
malfunction, which in turn can lead to injuries or death. 
• Protect files stored on exchangeable storage media from malicious software by taking 

suitable protection measures, e.g. virus scanners. 
 

http://www.siemens.com/industrialsecurity
http://support.automation.siemens.com/
http://support.automation.siemens.com/
http://www.siemens.com/industrialsecurity
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 SINAMICS V-ASSISTANT 2 
 

 

 
SINAMICS V-ASSISTANT engineering tool is designed for faster commissioning and 
diagnostics for the SINAMICS V90 drives with the PROFINET interface (referred to as 
SINAMICS V90 PN). The software runs on a personal computer with Windows operating 
systems and utilizes graphical user interface to interact with users and communicates with 
SINAMICS V90 PN via USB. It can be used to modify parameters and monitor status of 
SINAMICS V90 PN. 

2.1 SINAMICS V-ASSISTANT operating environment 
SINAMICS V-ASSISTANT runs on the following operating systems: 

● Windows XP SP3 (Home) 

● Windows XP SP3 (Professional) 

● Windows 7 32 bit (Home Premium) 

● Windows 7 32 bit (Professional) 

● Windows 7 32 bit (Ultimate) 

● Windows 7 64 bit (Home Premium) 

● Windows 7 64 bit (Professional) 

● Windows 7 64 bit (Ultimate) 

 

 Note 

The minimum screen resolution must be 1024*768. 
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2.2 Device combination 
The tables below show the combination of SINAMICS V90 PN servo drives and SIMOTICS 
S-1FL6 servo motors.  

Combination between V90 PN 200 V variant drives and low inertia motors 
 
SIMOTICS S-1FL6 servo motor SINAMICS V90 PN servo drive 
Type Rated 

torque 
(Nm) 

Rated 
power 
(kW) 

Rated 
speed 
(rpm) 

Shaft 
height 
(mm) 

Motor ID Order number1) Order number Frame 
size 

Power 
supply Without 

brake 
With 
brake 

Low 
inertia 

0.16 0.05 3000 20 42 * 43 1FL6022-2AF21-1A❑1 6SL3210-
5FB10-1UF0 

FSB 1/3-
phase 
200 VAC 
to 
240 VAC 

10001 10030 1FL6022-2AF21-1M❑1 
0.32 0.1 3000 20 46 47 1FL6024-2AF21-1A❑1 

10002 10031 1FL6024-2AF21-1M❑1 
0.64 0.2 3000 30 50 * 51 1FL6032-2AF21-1A❑1 6SL3210-

5FB10-2UF0 10003 10032 1FL6032-2AF21-1M❑1 
1.27 0.4 3000 30 54 * 55 1FL6034-2AF21-1A❑1 6SL3210-

5FB10-4UF1 10004 10033 1FL6034-2AF21-1M❑1 
2.39 0.75 3000 40 58 * 59 1FL6042-2AF21-1A❑1 6SL3210-

5FB10-8UF0 
FSC 

10005 10034 1FL6042-2AF21-1M❑1 
3.18 1 3000 40 62 * 63 1FL6044-2AF21-1A❑1 6SL3210-

5FB11-0UF1 
FSD 3-phase 

200 VAC 
to 
240 VAC 

10006 10035 1FL6044-2AF21-1M❑1 
4.78 1.5 3000 50 66 * 67 1FL6052-2AF21-0A❑1 6SL3210-

5FB11-5UF0 10007 10036 1FL6052-2AF21-0M❑1 
6.37 2 3000 50 70 * 71 1FL6054-2AF21-0A❑1 6SL3210-

5FB12-0UF0 10008 10037 1FL6054-2AF21-0M❑1 
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Combination between V90 PN 400V variant drives and high inertia motors 
 
SIMOTICS S-1FL6 servo motor SINAMICS V90 PN servo drive 
Type Rated 

torque 
(Nm) 

Rated 
power 
(kW) 

Rated 
speed 
(rpm) 

Shaft 
height 
(mm) 

Motor ID Order number1) Order number Fram
e size 

Power 
supply Without 

brake 
With 
brake 

High 
inertia 

1.27 0.4 3000 45 18 * 19 1FL6042-1AF61-0A❑1 6SL3210-5FE10-
4UF0 

FSAA 3-phase 
380 VAC 
to 
480 VAC 

10009 10038 1FL6042-1AF61-0L❑1 
2.39 0.75 3000 45 20 * 21 1FL6044-1AF61-0A❑1 6SL3210-5FE10-

8UF0 
FSA 

10010 10039 1FL6044-1AF61-0L❑1 
3.58 0.75 2000 65 22 23 1FL6061-1AC61-0A❑1 6SL3210-5FE11-

0UF0 10011 10040 1FL6061-1AC61-0L❑1 
4.78 1.0 2000 65 24 * 25 1FL6062-1AC61-0A❑1 

10012 10041 1FL6062-1AC61-0L❑1 
7.16 1.5 2000 65 26 * 27 1FL6064-1AC61-0A❑1 6SL3210-5FE11-

5UF0 
FSB 

10013 10042 1FL6064-1AC61-0L❑1 
8.36 1.75 2000 65 28 29 1FL6066-1AC61-0A❑1 

10014 10043 1FL6066-1AC61-0L❑1 
9.55 2.0 2000 65 30 * 31 1FL6067-1AC61-0A❑1 6SL3210-5FE12-

0UF0 10015 10044 1FL6067-1AC61-0L❑1 
11.9 2.5 2000 90 32 33 1FL6090-1AC61-0A❑1 

10016 10045 1FL6090-1AC61-0L❑1 
16.7 3.5 2000 90 34 * 35 1FL6092-1AC61-0A❑1 6SL3210-5FE13-

5UF0 
FSC 

10017 10046 1FL6092-1AC61-0L❑1 
23.9 5.0 2000 90 36 * 37 1FL6094-1AC61-0A❑1 6SL3210-5FE15-

0UF0 10018 10047 1FL6094-1AC61-0L❑1 
33.4 7.0 2000 90 38 * 39 1FL6096-1AC61-0A❑1 6SL3210-5FE17-

0UF0 10019 10048 1FL6096-1AC61-0L❑1 

1) The symbol ❑ in the motor order numbers is for optional configurations (mechanics). Refer 
to the motor rating plate explanation in SINAMICS V90, SIMOTICS S-1FL6 Operating 
Instructions for detailed information. 
2) The Motor ID values marked with an asterisk (*) are the default incremental motor IDs for 
V90 PN drives. If you have connected a different motor to the drive, you need to configure 
the motor ID manually. 
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 User interface 3 
3.1 Working modes 

When you start SINAMICS V-ASSISTANT, the following window appears for you to select a 
working mode: 

 
The functions of SINAMICS V-ASSISTANT vary with the working modes. 

● Online mode: SINAMICS V-ASSISTANT communicates with the target drive, which is 
connected with PC by a USB cable. 

Select the online mode, a list of all the connected drives is displayed. Select the target 
drive and click the following button.  

 
SINAMICS V-ASSISTANT automatically creates a new project to save all the parameter 
settings from the target drive and enters the main window. 

 
  Note 

If SINAMICS V-ASSISTANT fails to detect the connected drive immediately, please wait 
for a while and then plug in the USB cable again. 
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● Offline mode: SINAMICS V-ASSISTANT does not communicate with any connected 
drive. 

Two options are available for your choice:  

 
– If you select the first option, you must select a drive from the following window: 
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Select the product type and firmware version from the drop-down lists respectively. 

 
Select the order number of a drive. Click  to save the factory settings of the 
selected drive to the new project and enter the main window; or otherwise, click 

 to cancel.  
 

  Note 

To obtain the firmware version, you can view r29018 on BOP (Basic Operator Panel). For 
more information, refer to SINAMICS V90, SIMOTICS S-1FL6 Operating Instructions. 

 

– If you select the second option, you need to select an existing project in the following 
directory as the current project and enter the main window: 

 
 

① The default location is: xxx/Siemens/V-ASSISTANT/Project. 
xxx: SINAMICS V-ASSISTANT setup root directory. 

② Only .prj format is available. 
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Status indicators 
In the main window of SINAMICS V-ASSISTANT, the current working mode is indicated by 
the status indicators at the upper right of the main window: 
 

 
Online 

 
Offline 

You can switch the working mode between the two modes. For more information, refer to 
Section "Switch menu (Page 24)". 

Compare parameters 
When you switch the working mode from offline to online, the following question will appear 
to remind you to save the current project: 

 
You can click  to save the project; or otherwise, you can click  to give 
up saving. 

Then SINAMICS V-ASSISTANT automatically compares all parameter settings between the 
current project and the connected drive: 

 
If any inconsistency is detected, the following window will appear: 
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Click the first button to upload all parameter values of the connected drive to the current 
project; or otherwise, click the second button to upload all parameter values of the current 
project to the connected drive. 
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3.2 User interface - overview 

 
① Menu bar 
② Toolbar 
③ Task navigation 
④ Function mask 
⑤ Alarm window 

Menu bar 
The menu bar is located at the top of the user interface. You can find various commands and 
functions for basic operations of SINAMICS V-ASSISTANT. For more information, see 
Section "Menu bar (Page 19)". 

Toolbar 
The toolbar is located below the menu bar and provides direct access to the essential 
functions of SINAMICS V-ASSISTANT. For more information, see Section "Toolbar 
(Page 29)". 

Task navigation 
Task navigation lists the user tasks for users to fulfill. Each task contains different functions 
which facilitate users to parameterize all functions of V90 drives and monitor or diagnose the 
drives. For more information, see Chapter "Task navigation (Page 31)". 
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Function mask 
The function mask provides the user interface of each user task for users to implement 
related functions. 

Alarm window 
In online mode, the current faults and alarms are displayed in a list with the corresponding 
type, number and name. In offline mode, the alarm window is disabled. For more 
information, see Section "Alarm window (Page 30)". 

3.3 Menu bar 

3.3.1 Menu bar - overview 
The menu bar lists the menu items for users to manage the projects, switch the interface 
language, or view the online help: 

Project menu (Page 19) 

Edit menu (Page 23) 

Switch menu (Page 24) 

Tools menu (Page 25) 

Help menu (Page 29)  

3.3.2 Project menu 
This menu contains commands for creating, opening, saving, printing,or exiting from a 
project as well as switching the interface language. You can choose any menu command 
here for project management. 

● New project 

● Open project 

● Save project 

● Save project as 

● Print 

● Language 

● Exit 

3.3.2.1 Project -> New project 
When SINAMICS V-ASSISTANT is working in offline mode, you can use this menu 
command to create a new project. To proceed, refer to Selecting drive (Page 33). 
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3.3.2.2 Project -> Open project 
When SINAMICS V-ASSISTANT is working in offline mode, you can use this menu 
command to open an existing project in the following window: 

 
 

① The default location is: xxx/Siemens/V-ASSISTANT/Project. 
xxx: SINAMICS V-ASSISTANT setup root directory. 

② Only .prj format is available. 
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3.3.2.3 Project -> Save project 

Online mode/offline mode 
You can use this menu command to save the changed configuration to the current project. If 
this menu command is used for the first time, it is the same as "Project -> Save project as... 
(Page 22)". You can specify the file name and directory in the following window: 

 
 

① The default location is: xxx/Siemens/V-ASSISTANT/Project. 
 xxx: SINAMICS V-ASSISTANT setup root directory. 

② Only .prj format is available. 
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3.3.2.4 Project -> Save project as... 

Online mode/offline mode 
You can use this menu command to save the current project with a specified file name and 
directory in the following window: 

 
 

① The default location is: xxx/Siemens/V-ASSISTANT/Project. 
 xxx: SINAMICS V-ASSISTANT setup root directory. 

② Only .prj format is available. 

3.3.2.5 Project -> Print 

Online mode/offline mode 
You can use this menu command to print the user interface of the selected function from 
"Task navigation (Page 31)". 
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3.3.2.6 Project -> language 

Online mode/offline mode 
You can use this menu command to switch the interface language as desired. The default 
languages of SINAMICS V-ASSISTANT are English and Chinese. For installation packages 
of more languages, visit this address (http://www.siemens.com/sinamics-v-assistant). After 
you download the desired installation package to your PC and run it, you can switch the 
interface language to the corresponding language. 

3.3.2.7 Project -> Exit 

Online mode/offline mode 
You can use this menu command to exit from SINAMICS V-ASSISTANT directly. 

3.3.3 Edit menu 
This menu contains commands for cutting, copying and editing the parameter values or 
technical data related to the motor and drive. 

● Cut 

● Copy 

● Paste 

3.3.3.1 Edit -> Cut 
The command deletes the selected objects, for example, the parameter values from the user 
interface, and copies them to the clipboard. 

Alternatively, you can use  from the toolbar. 
 

 Note 

This menu command can only be used to modify the values in "Viewing all parameters 
(Page 47)". 

 

3.3.3.2 Edit -> Copy 
The command is used to copy selected objects, for example, parameter values, order 
number or the rated power of the drive or motor, to the clipboard. 

http://www.siemens.com/sinamics-v-assistant
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Alternatively, you can use  from the toolbar. 
 

 Note 

You can only use this menu command on the following function masks: 
• Selecting drive (Page 33) 
• Selecting motor (Page 35) 
• Viewing all parameters (Page 47) 
• Signal (Page 49) 

 

3.3.3.3 Edit -> Paste 
This menu command copies the clipboard content to the input field. The copied content will 
be inserted in a position determined with a mouse click. 

Alternatively, you can use  from the toolbar. 
 

 Note 

You can only use this menu command to modify the values in Viewing all parameters 
(Page 47). 

 

3.3.4 Switch menu 
This menu contains the following two commands to switch SINAMICS V-ASSISTANT 
between online mode and offline mode. 

●  Go offline 

●  Go online 

3.3.4.1 Switch -> Go offline 
When SINAMICS V-ASSISTANT is working in online mode, you can use this menu 
command to switch to offline mode. 

Alternatively, you can use  from the toolbar. 

3.3.4.2 Switch -> Go online 
When SINAMICS V-ASSISTANT is working in offline mode, you can use this menu 
command to switch to online mode. 

Alternatively, you can use  from the toolbar. 
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3.3.5 Tools menu 
The tools menu contains the following menu commands: 

● Tools -> Save parameters to ROM (Page 25) 

● Tools -> Restart drive (Page 25) 

● Tools -> Reset absolute encoder (Page 26) 

● Tools -> Factory default (Page 26) 

● Tools -> Upload parameters (Page 28) 

3.3.5.1 Tools -> Save parameters to ROM 
You can use this menu command to save the parameters from RAM to ROM in the drive. 
The following window will appear to display the saving process: 

 
Alternatively, you can use  from the toolbar. 

3.3.5.2 Tools -> Restart drive 
You can use this menu command to restart the drive. The following reminder will appear: 
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If you click , then the following information will appear: 

 
Click  and the drive is reset successfully. 

3.3.5.3 Tools -> Reset absolute encoder 
In online mode, if SINAMICS V-ASSISTANT is connected with an absolute encoder, you can 
use this menu command to set the current position of the absolute encoder as the reference 
point. 

3.3.5.4 Tools -> Factory default 

Online 
Select this menu command and the following reminder will appear: 

 



 User interface 
 3.3 Menu bar 

SINAMICS V-ASSISTANT Online Help 
Operating Manual, 05/2016, A5E38017830 27 

● If you click , then the following information window will appear: 

 
When the process is finished, the window disappears automatically. 

● If you click , the operation will be aborted. 

Offline 
Select this menu command and the following reminder will appear: 
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● If you click , after the parameters are reset to their factory defaults, the 
following information will appear: 

 
Click  to close the information window. To save the project, please refer to 
Section "Project -> Save project (Page 21)". 

● If you click , the operation is aborted. 

3.3.5.5 Tools -> Upload parameters 
 

 Note 

This menu command is only available in online mode. 
 

You can use the menu command to upload parameters from the drive to SINAMICS V-
ASSISTANT. The following window will appear to show the process: 

 
After the process is complete, the values of the same parameters in SINAMICS V-
ASSISTANT will be replaced by those in the drive automatically. 
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3.3.6 Help menu 
The Online help quickly provides you with information about drive selection, 
parameterization, commissioning and diagnostics of SINAMICS V-ASSISTANT. 

● Help -> View help (Page 29) 

● Help -> About SINAMICS V-ASSISTANT... (Page 29) 

3.3.6.1 Help -> View help 
You can use this menu command to display the content of SINAMICS V-ASSISTANT Online 
help. 

3.3.6.2 Help -> About SINAMICS V-ASSISTANT... 
You can use this menu command to display the following information window for SINAMICS 
V-ASSISTANT. 

 

3.4 Toolbar 
The icons of the toolbar provide quick access to the commands in the menu bar or functions 
from Task navigation (Page 31). 

 

 New project (Page 19) 

 Open project (Page 20)  

 Save project (Page 21)  

 Print (Page 22)  

 Cut (Page 23) 
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 Copy (Page 23) 

 Paste (Page 24) 

 Go offline (Page 24)  

 Go online (Page 24) 

 Save parameters to ROM (Page 25) 

 Upload parameters (Page 28) 

 Viewing all parameters (Page 47) 

 Trace (Page 65)  

 Test motor (Page 54) 

 Help (Page 29) 

3.5 Alarm window 

Alarm window overview 

 
① Alarm type: 

 : Fault 
 : Alarm 

Faults have priority over alarms in display. 

③ Alarm name and description 

② Alarm number ④ Acknowledge All: 
Clears the faults in the buffer area of the drive 

 

3.6 Function keys and shortcuts 
For frequently called functions, corresponding function keys and shortcuts are provided. 

Function keys in SINAMICS V-ASSISTANT 
 
[F1] → Calls the context sensitive Online help 
[Ctrl+X] → Edit -> Cut (Page 23) 
[Ctrl+C] → Edit -> Copy (Page 23) 
[Ctrl+V] → Edit -> Paste (Page 24) 
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 Task navigation 4 
 

 

 
 
Task Sub-functions 
Selecting drive (Page 32) • Selecting drive (Page 33) 

• Selecting motor (Page 35) 
• Control mode (Page 36) 
• Jog (Page 36) 

Setting PROFINET 
(Page 38) 

• Selecting telegram (Page 38) 
• Configuring network (Page 40) 

Parameterizing (Page 41) • Configuring ramp function (Page 42) 
• Setting limits (Page 43) 
• Configuring inputs/outputs (Page 45) 
• Viewing all parameters (Page 47) 
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Task Sub-functions 
Commissioning (Page 49) • Testing interface (Page 49) 

• Testing motor (Page 54) 
• Optimizing drive (Page 54) 

Diagnostics (Page 64) • Monitoring status (Page 64) 
• Tracing signals (Page 65) 
• Measuring machine (Page 69) 

4.1 Selecting drive 

 
 
① Drive selection Select a drive in this field. 

For more information, refer to Section "Selecting drive (Page 33)". 
② Motor selection Select a motor in this field. 

For more information, refer to Section "Selecting motor (Page 35)". 
③ Control mode Select a control mode in this field. 

For more information, refer to Section "Control mode (Page 36)". 
④ Jog Test the Jog function in this field. 

For more information, refer to Section "Jog (Page 36). 
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4.1.1 Selecting drive 

Online mode 
When you choose to work in online mode, a list of connected drive type(s) is displayed for 
your selection: 

 
Select the target drive type, and click  to establish communication between 
SINAMICS V-ASSISTANT and the drive. SINAMICS V-ASSISTANT reads all parameter 
settings from the connected drive and the main window displays the drive information on the 
following panel: 

 
The following drive information is displayed: 

● Order number 

● Line supply 

● Rated power 

● Rated current 

 
  Note 

 is disabled in online mode as shown in the above drive selection 
window. 
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Offline mode 
When you are working in offline mode, SINAMICS V-ASSISTANT does not communicate 
with the connected drive(s). 

You can click  to change the drive type in the following window: 

 
Select the order number of the target drive. Click  to save the factory settings of 
the selected drive to the new project and enter the main window; or otherwise, click 

 to cancel. 



 Task navigation 
 4.1 Selecting drive 

SINAMICS V-ASSISTANT Online Help 
Operating Manual, 05/2016, A5E38017830 35 

4.1.2 Selecting motor 

Online mode  

● If the connected motor is equipped with an absolute encoder,  is disabled. 

 
 

  Note 

In the order number, "x" is a wildcard; for more information about "A\G", please refer to 
SINAMICS V90, SIMOTICS S-1FL6 Operating Instructions. 

 

● If the connected motor is equipped with an incremental encoder, click  
and the motor list is displayed. 

 
Select a motor from the list and click the following button to confirm your selection: 
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  Note 

You can click "name plate" in the above window to see the specific location of the name 
plate on the motor. 

 

Offline mode 
● If you choose to create a new project, you need to select a drive first, then the information 

of the default motor is displayed. 

● If you choose to open an existing project, the saved motor information is displayed. 

● If you switch from online mode to offline mode, you can select the motor by clicking 
. 

4.1.3 Control mode 

Online mode/offline mode 
SINAMICS V90 PN can work in speed control mode. You can see it from the window below: 

 

4.1.4 Jog 
Jog function is only available in online mode. You can configure this function on the following 
panel: 
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● To start the Jog function, you can enter the Jog speed. Click , 
then the following warning will appear: 

 
Click  and run the drive counter-clockwise/clockwise by clicking the following 
two buttons respectively: 

 

  

Then the actual speed, actual torque, actual current and actual utilization will be 
displayed. 

●  To stop the Jog function, you can click  in the following window 
and SINAMICS V-ASSISTANT will release the control priority. 

 
 

 Note 

The Jog speed should not be too fast. Otherwise, the machine axes will get out of control 
due to possible communication delay. 
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4.2 Setting PROFINET 

 
You can select the desired telegram and configure the network under this mask. 

4.2.1 Selecting telegram 
In this area, you can see the activated control mode and telegram. If you desire to change 
the telegram, you can click the drop-down list and select the desired telegram. 

 
After you select a new telegram, the displayed process data changes according to the 
selected telegram. You can view all the PZDs of the selected telegram with the drop-down 
list and read their hexadecimal values from the first row of the table. 
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The PZD in green indicates that it has a bit definition. You can read the binary value of each 
bit from the table. 

 

Supported telegrams 
SINAMICS V90 PN supports standard telegrams and Siemens telegrams for speed control 
mode. You can select the desired telegram with parameter p0922. See the following table for 
details. 

From the perspective of the drive unit, the received process data represents the receive 
words and the process data to be sent to the send words. 

 
Telegram Maximum number of PZD Description 

Receive word Send word 
Standard telegram 1 2 2 p0922 = 1 
Standard telegram 2 4 4 p0922 = 2 
Standard telegram 3 5 9 p0922 = 3 
Standard telegram 5 9 9 p0922 = 5 
Siemens telegram 102 6 10 p0922 = 102 
Siemens telegram 105 10 10 p0922 = 105 
 One PZD = one word 

Standard telegram 5 and Siemens telegram 105 can only be used when the V90 PN connects to the SIMATICS S7-1500. 
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Standard telegrams 
 
Tele-
gram 

1 2 3 5 102 105 

Appl. 
class 

1 1 1, 4 4 1, 4 4 

PZD1 STW1 ZSW1 STW1 ZSW1 STW1 ZSW1 STW1 ZSW1 STW1 ZSW1 STW1 ZSW1 
PZD2 NSOLL

_A 
NIST_A NSOLL

_B 
NIST_B NSOLL

_B 
NIST_B NSOLL

_B 
NIST_B NSOLL

_B 
NIST_B NSOLL

_B 
NIST_
B 

PZD3 

  

PZD4 STW2 ZSW2 STW2 ZSW2 STW2 ZSW2 STW2 ZSW2 STW2 ZSW2 
PZD5   G1_ST

W 
G1_ZS
W 

G1_ST
W 

G1_ZS
W 

MOMR
ED 

MELD
W 

MOMR
ED 

MELD
W 

PZD6    G1_XIS
T1 

XERR G1_XIS
T1 

G1_ST
W 

G1_ZS
W 

G1_ST
W 

G1_ZS
W 

PZD7     G1_XIS
T1 

XERR G1_XI
ST1 PZD8    G1_XIS

T2 
KPC G1_XIS

T2 
 

PZD9     G1_XIS
T2 

KPC G1_XI
ST2 PZD10        

4.2.2 Configuring network 
This function is only available in online mode. You can configure this function on the 
following panel: 

 
In online mode, the IP address of the connected drive is displayed in area "②" automatically. 
You can define the PN name of station in area "①". Note that only numbers (0 to 9), 
lowercase letters ("a" to "z") and characters ("-" and ".") in English are permissible. In 
addition, you can modify the IP address in area "②" as desired. Click button "③" to save 
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and activate the settings. Restart the drive and then the PN name and IP address you set 
become active and appear in areas "④" and "⑤". 

 

 Note 

If you have also configured the IP protocol in TIA Portal, then the IP protocol set in TIA Portal 
takes the first priority and displays in area "⑤" as the actual active IP protocol. 

 

4.3 Parameterizing 

 
Totally, there are four functions available in the S control mode: 

● Configuring ramp function (Page 42) 

● Setting limits (Page 43) 

● Configuring inputs/outputs (Page 45) 

● Viewing all parameters (Page 47) 
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4.3.1 Configuring ramp function 

Ramp-function generator 
The ramp-function generator is used to limit acceleration in the event of abrupt setpoint 
changes and thus helps prevent load surges during drive operation. 

The ramp-up time p1120 and ramp-down time p1121 can be used to set acceleration and 
deceleration ramps separately. This allows a smoothed transition in the event of setpoint 
changes. 

 
To activate this function, select "②" from the drop-down list in the above window or set bit 0 
of p29108 on the BOP first. Make sure you have properly connected the SINAMICS V90 PN 
drive with the motor and the encoder works normally; otherwise, the ramp function generator 
is disabled due to faults (for example, F31117 and F52983, etc.) despite that it is displayed 
active in the above window. To activate the internal configuration of the ramp function 
generator, you have to re-connect the motor and restart the drive. Then, you can continue 
with either type of the ramp function generator. 

Two types of ramp-function generator are available. You can specify the parameters on the 
corresponding panels: 

● Basic ramp-function generator 
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● Extended ramp-function generator 

 

4.3.2 Setting limits 

4.3.2.1 Torque limit 
You can specify the corresponding parameters on the following panel: 

 

Source of torque limit 
Two sources in total are available for torque limit. You can select one of them via the digital 
input signal TLIM: 
 
Digital input (TLIM) Torque limit 
0 Internal torque limit 1 
1 Internal torque limit 2 
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When the torque setpoint reaches torque limit, the torque is limited to the value selected by 
TLIM. 

 

 Note 

You can switch between the two sources and modify their values when the servo drive is 
running. 

 

Refer to Section "Digital inputs (DIs) (Page 51)" for more information about the digital input 
signal TLIM. 

Overall torque limit 
Besides the above two sources, an overall torque limit is available. The overall torque limit 
takes effect when an emergency stop (OFF3) happens. In this case, the servo drive brakes 
with a maximum torque. 

4.3.2.2 Speed limit 
You can specify the corresponding parameters on the following panel: 

 

Source of speed limit 
Two sources in total are available for speed limit. You can select one of them via the digital 
input signal SLIM: 
 
Digital input (SLIM) Speed limit 
0 Internal speed limit 1 
1 Internal speed limit 2 

 

 

 Note 

You can switch between the two sources and modify their values when the servo drive is 
running. 
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When the speed setpoint reaches the speed limit, an alarm occurs. 

Refer to Section "Digital inputs (DIs) (Page 51)" for more information about the digital input 
signal SLIM.  

Overall speed limit 
Besides the above two channels, an overall speed limit is available. 

4.3.3 Configuring inputs/outputs 
Two sub-functions are available as follows: 

● Digital inputs (DIs) (Page 51) 

● Digital outputs (DOs) (Page 52) 

4.3.3.1 Assigning digital inputs 
You can assign digital inputs on the following panel: 

 
Four signals in total can be freely linked to digital inputs, for more information, refer to 
Section "Digital inputs (DIs) (Page 51)". 

Click the cells with white background in the table. Two options are displayed in the drop-
down list: Assign and Cancel. Select "Assign" to link the digital input with the corresponding 
signal. Then the current row displays grey. Otherwise, select "Cancel" to release the link. 
The current row will then display white. 
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4.3.3.2 Assigning digital outputs 
You can assign digital outputs on the following panel: 

 
Seven signals in total can be freely linked to digital outputs. For more information, refer to 
Section "Digital outputs (DOs) (Page 52).  

Click the cells with white background in the table. Select "Assign" to link the digital input with 
the corresponding signal. Then the current cell displays grey. 

DO signal reverse 
You can reverse the logics of DO1 and DO2 by activating the checkboxes in the following 
function area or setting the bit 0 and bit 1 of parameter p748: 

 
After the DO port is reversed, an "/" appears before the DO port to indicate that the logic of 
the signal assigned to this port has been reversed.  
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4.3.4 Viewing all parameters 
You can configure all editable parameters in this field: 

 
 
Field Description 
Group filter Views parameters according to different groups. 
Find Filters the parameter list according to the entered text. The filtering is done after you 

enter the desired text. 
Factory 
default 

You can click the following button to reset all parameters to their factory settings: 

 
For more information, refer to Section "Tools -> Factory default (Page 26)". 
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Field Description 
Save 
changes 

You can click the following button to save the changes compared to the de-
faults/factory settings into an .html file which can be further used for documentation 
purposes or as an reference for BOP commisioning. 

 
Save in the following window: 

 

①: The default location is: xxx/Siemens/V-ASSISTANT/Project. 
 xxx: SINAMICS V-ASSISTANT setup root directory 

②: Only .html format is available. 
Table All parameters are displayed with the following information: 

• Group 
• Parameter number 
• Name 
• Value 
• Unit 
• Range 
• Factory setting 
• Effect type 
Note: 
In the value related column, values with white background are editable. 
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4.4 Commissioning 

4.4.1 Testing interface 

4.4.1.1 I/O simulation 
When SINAMICS V-ASSISTANT is working in online mode, you can view the I/O status on 
the following panel:  

 



Task navigation  
4.4 Commissioning 

 SINAMICS V-ASSISTANT Online Help 
50 Operating Manual, 05/2016, A5E38017830 

 
Area Item Description 

① DI1~DI4 Every digital input can be linked with either of the four 
internal signals. 

Note: 
For more information about the number and definition of signals, refer to Section"Digital inputs 
(DIs) (Page 51)". 

② DO1~DO6 Every digital output can be freely linked with either of the 
seven internal signals.  

Note: 
DO1 and DO2 can be reversed. For more information about the number and definition of sig-
nals, refer to Section"Digital outputs (DOs) (Page 52)". 

③  
Clicking this button enables DO simulation. If you desire 
to disable this function, click the following button: 

 

④  Signal is enabled Before DO is reversed: 
Indicates high-voltage (or logic 1) is on the digital in-
put/output. 
After DO is reversed: 
Indicates low-voltage (or logic 0) is on the digital in-
put/output. 

 Signal is disabled Before DO is reversed: 
Indicates low-voltage (or logic 0) is on the digital in-
put/output. 
After DO is reversed: 
Indicates high-voltage (or logic 1) is on the digital in-
put/output. 

 DO is reversed Indicates the logic of the DO is reversed. 
After the DO is reversed, an "/" appears before the DO 
port. 

 

 

 Note 
• This function is unavailable but can be displayed in offline mode. 
• The status of each indicator are updated every 0.5 s. 
• You can change the signal link as you desire. For more information, refer to Section 

"Configuring inputs/outputs (Page 45)". 
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DI signals 
You can view the name, description, and value of individual DI signals on the following 
panel: 

 

DO signals 
You can view the name, description, and value of individual DO signals on the following 
panel: 

 

4.4.1.2 Digital inputs (DIs) 
You can assign a maximum of four internal digital input signals to the SINAMICS V90 PN 
servo drive. For detailed information about these signals, see the table below: 
 
Name Type Description 
RESET Edge 

0→1 
Reset alarms 
• 0→1: Reset alarms 

TLIM Level Torque limit selection 
Two internal torque limit sources can be selected with the digital input signal 
TLIM. 
• 0 = internal torque limit 1 
• 1 = internal torque limit 2 
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Name Type Description 
SLIM Level Speed limit selection 

Two internal speed limit sources can be selected with the digital input signal 
SLIM. 
• 0 = internal speed limit 1 
• 1 = internal speed limit 2 

EMGS Level Emergency stop 
• 0 = Emergency stop 
• 1 = Servo drive is ready to run 

Wiring 
The digital inputs support both PNP and NPN types of wirings. You can find detailed 
information from the following diagrams: 
 

  

NPN wiring PNP wiring 

4.4.1.3 Digital outputs (DOs) 
You can assign a maximum of seven internal digital output signals to the SINAMICS V90 PN 
servo drive. For detailed information about these signals, see the table below: 
 
Name Description 
RDY Servo ready 

• 1: ready to operate 
• 0: drive not ready (alarm occurs or enable signal is missing) 

FAULT Fault 
• 1: in fault status 
• 0: no fault 



 Task navigation 
 4.4 Commissioning 

SINAMICS V-ASSISTANT Online Help 
Operating Manual, 05/2016, A5E38017830 53 

Name Description 
ZSP Zero speed detection 

• 1: motor speed is equal with or lower than the zero speed (can be set with parameter 
p2161). 

• 0: motor speed is higher than zero speed + hysteresis (10 rpm). 

TLR Torque limit reached 
• 1: the generated torque has nearly (internal hysteresis) reached the value of the 

positive torque limit, negative torque limit or analog torque limit 
• 0: the generated torque has not reached the limit 

MBR Motor holding brake 
• 1: motor holding brake is closed 
• 0: motor holding brake is released 
Note: MBR is only status signal because the control and the power supply of the motor 
holding brake is realized with separate terminals. 

OLL Overload level reached 
• 1: motor has reached the parameterizable output overload level (p29080 in % of 

rated torque, default: 100%, max: 300%) 
• 0: motor has not reached the overload level 

RDY_ON Ready for servo on 
• 1: ready to servo on 
• 0: drive is not ready for servo on (fault occurs, main power supply is missing, or 

STW1.1 and STW1.2 are not set to 1) 
Note: After the drive is servo on, the signal remains in 1 status unless the above abnor-
mal cases happen. 

Wiring 
The digital outputs support both PNP and NPN types of wirings. You can find detailed 
information from the following diagrams: 
 

  

NPN wiring PNP wiring 
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4.4.2 Testing motor 

4.4.2.1 Jog 
For detailed information about the Jog function, see Section "Jog (Page 36)". 

4.4.3 Optimizing drive 
You can select the desired tuning mode with the tabs on the following panel: 

 

Auto-tuning modes 

SINAMICS V90 PN supplies two auto-tuning modes: one-button auto tuning and real-time 
auto tuning. The auto tuning function can optimize control parameters with ratio of machine 
load moment of inertia (p29022) and set suitable current filter parameters to suppress the 
machine resonance automatically. You can change the dynamic performance of the system 
by setting different dynamic factors. 

● One-button auto tuning 

– One-button auto tuning estimates the machine load moment of inertia and mechanical 
characteristics with internal motion commands. To achieve the desired performance, 
you can execute the process many times before you control the drive with the host 
controller. The maximum speed is limited by the rated speed. 

● Real-time auto tuning 

– Real-time auto tuning estimates the machine load moment of inertia automatically 
while the drive is running with the host controller command. After enabling the servo 
on (SON), the real-time auto tuning function stays effective for the servo drive. If you 
do not need to estimate the load moment of inertia continuously, you can disable the 
function when the system performance is acceptable. 

4.4.3.1 One-button auto tuning 
 

 Note 

Before using the one-button auto tuning, move the servo motor to the middle of mechanical 
position to avoid approaching the actual machine position limit.  

 

With one-button auto tuning, the servo drive can automatically estimate the ratio of load 
moment of inertia. 
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Pre-conditions for one-button auto tuning 

● The ratio of machine load moment of inertia is unknown and needs to be estimated. 

● The motor is allowed to rotate clockwise and counter-clockwise. 

● The motor rotation position (p29027 defines that one revolution equals to 360 degree) is 
allowed by the machine. 

– For the motor with an absolute encoder: position limitation is defined by p29027 

– For the motor with an incremental encoder: the motor must be allowed to rotate freely 
about two rounds when tuning starts 

Implement the following steps to use the one-button auto tuning function: 
 
1. Select the dynamic factor in the following area: 

 
For more information about selecting the dynamic factor, refer to chapter "one-button 
auto tuning" in SINAMICS V90, SIMOTICS S-1FL6 Operating Instructions. 

2. Configure the test signal in the following area: 

 
Note: 
The recommended position amplitude (p29027) is 360°. 

3. Click the following button to configure the parameters for the one-button auto tuning 
function. 
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4. Set the parameters in the window below: 

 
Note: 
You can set the ratio of machine load moment of inertia (p29022) with the following 
methods: 
• Enter it manually if you have known the ratio of machine load moment of inertia 
• Estimate the ratio of machine load moment of inertia with one-button auto tuning 

(p29023.2 = 1). When you have executed the one-button tuning many times and 
obtained a stable value of p29022, you can stop estimating it by setting p29023.2 = 
0. 

Parameter p29028 is available when the multi-axis interpolation function is activated 
(p29023.7 = 1). If the axes are used as the interpolation axes, you need to set the same 
pre-control time constants (p29028) for them. 
The parameters in advanced settings window must be set carefully when the auto-tuning 
function is disabled (p29021 = 0). 

5. Click the following button to enable the function after the parameters are set. 

 

6. Click this button to start tuning. 
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7. After the tuning is completed, the tuning results window appears.  

 
Press this button to apply the tuning result. 

 
Press this button to abort the tuning result. 

 

8. Copy the tuned parameters from RAM to ROM to save them when the tuning is com-
pleted and the drive performance is acceptable. 

 

 

 Note 

After servo on, the motor will run with the test signal. 

When the one-button auto tuning process completes successfully, the parameter p29021 will 
be set to 0 automatically. You can also set the parameter p29021 to 0 before servo on to 
interrupt the one-button auto tuning. Before you save the parameters on the drive, make 
sure that p29021 has changed to 0. 

 

 Note 

Do not use the JOG function when you use the one-button tuning function. 
 

 Note 

After the one-button tuning function is activated, no operation will be allowed except the 
servo off and emergency stop.  

 

 Note 

After one-button auto tuning is activated, do not change other auto tuning related 
control/filter parameters since these parameters can be set automatically and your changes 
will not be accepted. 
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 Note 

One-button auto tuning can cause some changes of the control parameters. When the 
system rigidity is low, this may lead to a situation that when you set EMGS = 0, the motor 
needs take long time to emergency stop. 

 

Resonance suppression with one-button auto tuning (p29021=1, p29023.1=1) 
The resonance suppression function is used together with the one-button auto tuning 
function. The function is activated by default. 

The function can be activated/deactivated with bit 1 of p29023. 

Before you use the resonance suppression function with one-button auto tuning, make sure 
the load is mounted as required and the servo motor can rotate freely. When the one-button 
auto tuning process completes successfully, the servo drive automatically sets the following 
notch filter relevant parameters with actual machine characteristic. Four current setpoint 
filters can be activated at most. You can check the following parameters in the tuning result 
window. 
 
Parameter Value range Default 

value 
Unit Description 

p1663 0.5 to 16000 1000 Hz Natural frequency of current notch filter 2 denomi-
nator. 

p1664 0.001 to 10 0.3 - Damp of current notch filter 2 denominator. 
p1665 0.5 to 16000 1000 Hz Natural frequency of current notch filter 2 numera-

tor. 
p1666 0.0 to 10 0.01 - Damp of current notch filter 2 numerator. 
p1668 0.5 to 16000 1000 Hz Natural frequency of current notch filter 3 denomi-

nator. 
p1669 0.001 to 10 0.3 - Damp of current notch filter 3 denominator. 
p1670 0.5 to 16000 1000 Hz Natural frequency of current notch filter 3 numera-

tor. 
p1671 0.0 to 10 0.01 - Damp of current notch filter 3 numerator. 
p1673 0.5 to 16000 1000 Hz Natural frequency of current notch filter 4 denomi-

nator. 
p1674 0.001 to 10 0.3 - Damp of current notch filter 4 denominator. 
p1675 0.5 to 16000 1000 Hz Natural frequency of current notch filter 4 numera-

tor. 
p1676 0.0 to 10 0.01 - Damp of current notch filter 4 numerator. 

 

 

 Note 
Notch filter remains active when the resonance suppression function is activated 
automatically. 

After one-button tuning, four filters can be activated at most. You can deactivate the notch 
filters by setting the parameter p1656. 
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4.4.3.2 Real-time auto tuning 
 

 Note 

Under operating conditions that impose sudden disturbance torque during 
acceleration/deceleration or on a machine that its rigidity is poor, auto tuning may not 
function properly, either. In such cases, use one-button auto tuning or manual tuning to 
optimize the drive. 

 

With real-time auto tuning, the servo drive can automatically estimate the ratio of load 
moment of inertia and set the optimum control parameters. 

Pre-conditions for the real-time auto tuning 

● The drive must be controlled by the host controller. 

● The machine actual load moment of inertia is different when the machine moves to the 
different positions. 

● Make sure that the motor has multiple accelerations and decelerations. Step command is 
recommended. 

● Machine resonance frequency changes when the machine is running. 

Implement the following steps to use the real-time auto tuning function: 
 
1. Select the dynamic factor in the following area: 

 
For more information about selecting the dynamic factor, refer to chapter "Real-time 
auto tuning" in SINAMICS V90, SIMOTICS S-1FL6 Operating Instructions. 

2. Click the following button to configure the parameters for the real-time auto tuning func-
tion. 
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3. Set the parameters in the window below: 

 
Note: 
You can set the ratio of machine load moment of inertia (p29022) with the following 
methods: 
• Enter it manually if you have known the ratio of machine load moment of inertia 
• Use the ratio of machine load moment of inertia estimated by the one-button auto 

tuning function directly 
• Estimate the ratio of machine load moment of inertia with real-time auto tuning 

(p29024.2 = 1). When you have obtained a stable value of p29022, you can stop 
estimating it by setting p29024.2 = 0. 

Parameter p29028 is available when the multi-axis interpolation function is activated 
(p29024.7 = 1). If the axes are used as the interpolation axes, you need to set the same 
pre-control time constants (p29028) for them.  
The parameters in advanced settings window must be set carefully when the auto-tuning 
function is disabled (p29021 = 0). 

4. Click the following button to start tuning after the parameters are set. 
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5. Perform the servo on for the drive with host controller and tuning starts.  
For example, you can use the following method to run the motor. 
Implement servo on for the drive with Jog. 

 
Enter the speed for the motor and press the direction button to let the motor run.  

 

6. To achieve the desired system performance, you can change the dynamic factors or 
related configuration parameters during tuning. 

7. If the drive performance is acceptable, disable the tuning function by servo off and set 
p29021 = 0. 

8. Copy the tuned parameters from RAM to ROM to save them. 

Resonance suppression with real-time auto tuning (p29021=3, p29024.6=1) 
The resonance suppression function is used together with the real-time auto tuning function. 
The function is activated by default. 

When you use real-time auto tuning function, you are recommended to disable the 
resonance suppression function to get a high dynamic performance if there is no resonance 
in the machine. 

The function can be activated/deactivated with the bit 6 of p29024. 

When you choose to use the resonance suppression function with real-time auto tuning, the 
servo drive performs real-time detection of the resonance frequency and configures the 
following notch filter relevant parameters accordingly: 
 
Parameter Value range Default 

value 
Unit Description 

p1663 0.5 to 16000 1000 Hz Natural frequency of current notch filter 2 denomina-
tor. 

p1664 0.001 to 10 0.3 - Damp of current notch filter 2 denominator. 
p1665 0.5 to 16000 1000 Hz Natural frequency of current notch filter 2 numerator. 
p1666 0.0 to 10 0.01 - Damp of current notch filter 2 numerator. 
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4.4.3.3 Manual tuning 
When the auto tuning function cannot reach the expected tuning results, you can disable the 
auto tuning function by setting the parameter p29021 and manually perform tuning: 

● p29021=5: auto tuning function is disabled and all control parameters are reset to tuning 
default values. 

● p29021=0: auto tuning function is disabled without changing control parameters. 

Parameter settings 
You can set the parameters on the following panel: 

 
Click  to reset the following parameters to their tuning defaults. The tuning 
default values of the parameters are different when you use the different drives and motors. 
The function of the button is not drive default so the tuning default values of the control 
parameters are different with their factory settings. 

● p1414 

● p1415 

● p1656 

● p1658 

● p1659 

● p29120 

● p29121 
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Resonance suppression with manual tuning (p29021=0) 
When both the resonance suppression with real-time auto tuning and one-button tuning 
mode cannot reach the suppression effect, you can do the resonance suppression by 
manually setting the following parameters: 
 
Parame-
ter 

Value range Default 
value 

Unit Description 

p1663 0.5 to 16000 1000 Hz Natural frequency of current notch filter 2 denominator. 
p1664 0.001 to 10 0.3 - Damp of current notch filter 2 denominator. 
p1665 0.5 to 16000 1000 Hz Natural frequency of current notch filter 2 numerator. 
p1666 0.0 to 10 0.01 - Damp of current notch filter 2 numerator. 
p1668 0.5 to 16000 1000 Hz Natural frequency of current notch filter 3 denominator. 
p1669 0.001 to 10 0.3 - Damp of current notch filter 3 denominator. 
p1670 0.5 to 16000 1000 Hz Natural frequency of current notch filter 3 numerator. 
p1671 0.0 to 10 0.01 - Damp of current notch filter 3 numerator. 
p1673 0.5 to 16000 1000 Hz Natural frequency of current notch filter 4 denominator. 
p1674 0.001 to 10 0.3 - Damp of current notch filter 4 denominator. 
p1675 0.5 to 16000 1000 Hz- Natural frequency of current notch filter 4 numerator. 
p1676 0.0 to 10 0.01 - Damp of current notch filter 4 numerator. 

Assume the notch frequency is fsp, notch width is fBB, and notch depth is K, then the filter 
parameters can be calculated as follows: 

p1663=p1665=fsp 

p1664=fBB / (2 × fsp) 

p1666=(fBB × 10(k/20) )/ (2 × fsp) 



Task navigation  
4.5 Diagnostics 

 SINAMICS V-ASSISTANT Online Help 
64 Operating Manual, 05/2016, A5E38017830 

4.5 Diagnostics 
 

4.5.1 Monitoring status 
 

 Note 

This function can only work in online mode. 
 

You can monitor the real-time value of motion related parameters. The motion data and 
product information are displayed on the following panel: 
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4.5.2 Tracing signals 
With this function, you can trace the performance of the connected drive in the current 
control mode on the following panel: 

 
 
Area Item Description 

 

① Trace configura-
tion  

Opens the window of trace configuration. For more information, 
refer to "Trace configuration (Page 68)". 

Start/stop trace  
(Only available in 
online mode) 

 
Starts recording the current trace.  
If you desire to stop the trace process, click the following button: 

 

② Cursors 
 

Changes the cursor shape from cross to arrow. 
When the cursor displays as an arrow, you can directly select a 
curve and use it for variable calculation.  
Note: 
The selected curve displays highlighted. 

 
If you click this button, you can move the selected curve freely 
after the cursor appears in the shape of a hand. 
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Area Item Description 
 

Auxiliary lines 
 

Vertical cursor: 
• In time domain chart, you can click this button to display 

coordinates t1 and t2 in the chart. You can move t1 or t2 
when the cursor changes to . 

• In frequency domain chart, activate this button to display a 
highlighted coordinate in the chart. You can move this coor-
dinate in the chart when the cursor changes to . 

 
Horizontal cursor: 
• In time domain chart, you can click this button to display 

coordinates y1 and y2 in the chart. You can move y1 or y2 
when the cursor changes to . 

• In frequency domain chart, the button is not available. 

Zoom 
 

Zooms in the current curves with a specified scale. 

 
Zooms out the current curves with a specified scale. 

 
Restores curves in the chart. 

File operation 
 

 
Opens an existing .trc file for curve display in the chart. 

 
Saves the current recording of values in the following file for-
mats: 
• .trc: trace curve files 
• .png: bode diagrams, time domain charts or frequency do-

main charts 

Note:  

In frequency domain chart, horizontal cursor button  is unavailable. 

③ Charts • Time domain chart: 

Displays the time chart in curves and records measured 
values of parameters. 

• Frequency domain chart: 

Available for mathematically computed curves and displays 
the Fourier transformation. 

④ Time domain chart 
T Coordinate T (time): 

• t1: Real-time value of coordinate t1 
• t2: Real-time value of coordinate t2 
• dt: Automatically calculated duration. 

The formula is as follows:  

dt = t2 - t1 
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Area Item Description 
 

Y Coordinate Y: 
• y1: Real-time value of coordinate y1 
• y2: Real-time value of coordinate y2 
• dy: Automatically calculated value range. 

The formula is as follows: 

dy = y2 - y1 
Y(T) • y(t1): Real-time value at the cross point of coordinate t1 

and selected curve. 
• y(t2): Real-time value at the cross point of coordinate t2 

and selected curve. 
• dy(t): Automatically calculated real-time value range. 

The formula is as follows: 

dy(t) = y(t2) - y(t1) 
Note: 
You can select a coordinate by clicking its designation, then the selected coordinate dis-
plays yellow. 
Frequency domain chart 
Frequency Displays real-time frequency value of the horizontal cursor 

coordinate in the chart. 
Amplitude Displays real-time amplitude value at the cross point of the 

horizontal cursor coordinate and curve. 

⑤ Curve selection Selects a curve to display in the chart. 
• Time domain chart: 

A maximum of six curves can be simultaneously displayed 
in the chart. 

• Frequency domain chart: 

Only one curve can be selected to display in the chart. 
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4.5.2.1 Trace configuration 

 
 
Index Function description 

① Click the following button to select the analog signal. 

 
Select a trace signal and click  to confirm your selection. Or otherwise, you can 
click  to cancel. 
Click the color bar to define the display color of the curve for the signal. 

② Click the following button to select the digital signal. 

 
Select a trace signal and click  to confirm your selection. Or otherwise, you can 
click  to cancel. 
Click the color bar to define the display color of the curve for the signal. 

③ Recording settings: 
You can select the factor and define the trace cycle clock, maximum duration and recording 
duration. 

If you desire to set the recording duration to the maximum duration, you can click  to 
copy the value. 
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Index Function description 

④ Seven trigger types are available for your selection: 
• Immediate recording (default settings) 
• Trigger on rising edge 

Note:  

The digital signals must be set to 1. Otherwise, the rising edge cannot be triggered. 
• Trigger on falling edge 

Note:  

The digital signals must be set to 0. Otherwise, the falling edge cannot be triggered. 
• Trigger within the scope 
• Trigger outside of the scope 
• Trigger at alarm 
• Trigger at fault 

Trigger type settings: 
• For the last six trigger types, you can select pre-trigger or post-trigger and the trigger 

signal. 
• For the fourth and fifth trigger types, you can enter the threshold upper/lower value in the 

textbox. 

4.5.3 Measuring machine 
The measuring function is used for controller optimization. With measuring function, you can 
directly inhibit the influence of higher-level control loops by means of simple 
parameterization, and analyze the dynamic response of individual drives. 

For easier handling of the controller optimization, predefined measuring functions are 
available for selection. The operating mode is automatically set depending on the measuring 
function.  

● Speed controller setpoint frequency response(before speed setpoint filter) 

The speed control loop is closed while all of the higher-level control loops are open. For 
the setpoint frequency response on the speed controller, the speed setpoint is activated 
by a PRBS signal. The evaluation of the signals is performed in the frequency range. 

● Speed control system(excitation after current setpoint filter) 

The speed control loop is closed while all of the higher-level control loops are open. For 
the measurement of the speed controller system on the speed controller, the speed 
setpoint is activated by a PRBS signal. The evaluation of the signals is performed in the 
frequency range. 

● Current controller setpoint frequency response(after current setpoint filter) 

For the reference frequency response on the current controller, the current setpoint is 
activated by a PRBS signal. The evaluation of the signals is performed in the frequency 
range. 



Task navigation  
4.5 Diagnostics 

 SINAMICS V-ASSISTANT Online Help 
70 Operating Manual, 05/2016, A5E38017830 

 Note 

Measuring machine is only available in online mode. 
 

Overview 

 
 
Area Item Description 

① Measuring functions • Speed controller setpoint frequency response(before speed setpoint filter) 
• Speed control system(excitation after current setpoint filter) 
• Current controller setpoint frequency response(after current setpoint filter) 

Amplitude The value of the signal amplitude to be applied. 
For the current controller, the specification is a relative value in percent. The value 
refers to the reference current (p2002). For the speed controller, the amplitude specifi-
cation is always in physical units. 

Offset DC component which is superimposed on the test signal. 
The value is normalized in the same way as the amplitude specification. Please note 
that the offset is subtracted again when the measured values are saved during runtime. 

Bandwidth Bandwidth of the measurement activated by a PRBS signal. 
Bandwidth = 1/(2*sample frequency). As only multiply of 2n for the minimum sampling 
time (0.25ms) is available, the bandwidths that can be implemented are quantized. 
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Area Item Description 

② Servo on/off Click  and the following warning appears:  

 
Confirm by clicking  to obtain the control priority for the connected drive.  
 
Then  becomes . If you desire to 
give up the control priority, you can directly click it. 

Start trace 
 

Click this button to start trace. 
Note: 
During the trace process, you cannot stop it but only wait until it is complete. 

③ Cursor 
 

Changes the cursor shape from cross to arrow. When the cursor displays as an arrow, 
you can directly select a curve and use it for variable calculation.  
Note: 
The selected curve displays highlighted. 

 
If you click this button, you can move the selected curve freely after the cursor appears 
in the shape of a hand. 

Auxiliary line 
 

Vertical cursor: 
In time domain chart, you can click this button to display coordinates t1 and t2 in the 
chart. You can move t1 or t2 when the cursor changes to . 
In frequency domain chart, activate this button to display a highlighted coordinate in the 
chart. You can move this coordinate in the chart when the cursor changes to .  

 
Horizontal cursor: 
• In time domain chart, you can click this button to display coordinates y1 and y2 in 

the chart. You can move y1 or y2 when the cursor changes to . 
• In frequency domain chart, the button is not available. 

Zoom 
 

Zooms in the current curves with a specified scale. 

 
Zooms out the current curves with a specified scale. 

 
Restores curves in the chart. 

File operation 
 

Opens an existing .trc file for curve display in the chart. 

 
Saves the current recording of values in the following file formats: 
• .trc: trace curve files 
• .png: time domain charts or frequency domain charts 
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Area Item Description 
Note:  

In frequency domain chart, horizontal cursor button  is unavailable. 

④ 
 

Chart • Time domain chart: 

Displays the time chart in curves and records measured values of parameters. 
• Frequency domain chart: 

Available for mathematically computed curves and displays the Fourier transfor-
mation. 

• Bode diagram: 

Available for mathematically computed curves.  
⑤ Time domain chart 

T Coordinate T (time): 
• t1: Real-time value of coordinate t1 
• t2: Real-time value of coordinate t2 
• dt: Automatically calculated duration 
The calculation formula is as follows:  
dt = t2 - t1 

Y Coordinate Y: 
• y1: Real-time value of coordinate y1 
• y2: Real-time value of coordinate y2 
• dy: Automatically calculated value range 
The calculation formula is as follows: 
dy = y2 - y1 

Y(T) • y(t1): Real-time value at the cross point of coordinate t1 and selected curve. 
• y(t2): Real-time value at the cross point of coordinate t2 and selected curve. 
• dy(t): Automatically calculated real-time value range. 
The calculation formula is as follows: 
dy(t) = y(t2) - y(t1) 

Note: 
You can select a coordinate by clicking its designation, then the selected coordinate displays yellow. 
Frequency domain chart 
Frequency Displays real-time frequency value of the horizontal cursor coordinate in the chart. 
Amplitude Displays real-time amplitude value at the cross point of the horizontal cursor coordinate 

and curve. 
Bode diagram 
Frequency Displays real-time frequency value of the horizontal cursor coordinate in the diagram. 
Amplitude Displays real-time amplitude value at the cross point of the horizontal cursor coordinate 

and the curve. 

⑥ Curve selection Selects a curve to display in the chart. 
• Time domain chart: 

A maximum of six curves can be simultaneously displayed in the chart. 
• Frequency domain chart: 

Only one curve can be selected to display in the chart. 
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